General service issue
Incident Report for MURAL
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 24, 2017 - 10:01 GMT-03:00
Investigating
MURAL is currently experiencing issues that result in murals not loading or connecting.
Posted over 1 year ago. Oct 24, 2017 - 08:54 GMT-03:00