Planned maintenance
Incident Report for MURAL
Resolved
This incident has been resolved.
Posted over 2 years ago. Feb 11, 2017 - 21:53 GMT-03:00
Monitoring
We're performing a planned upgrade of our server infrastructure. While no issues should be noticed, there might be unexpected degraded performance. Please stand by.
Posted over 2 years ago. Feb 11, 2017 - 16:39 GMT-03:00